Requirements

<< Click to Display Table of Contents >>

Navigation:  »No topics above this level«

Requirements

Requirements

 

Exchange Server Toolbox runs on any edition of the following operating systems:

Windows Server 2019 (64 Bit)

Windows Server 2016 (64 Bit)

Windows Server 2012 R2 (64 Bit)

Windows Server 2012 (64 Bit)

 

Exchange Server Toolbox is compatible with the following Microsoft Exchange Servers:

Microsoft Exchange Server 2019 (64 Bit)

Microsoft Exchange Server 2016 (64 Bit) (CU 11 or newer required)

Microsoft Exchange Server 2013 (64 Bit) (CU 21 or newer required)

 

Alternatively, you can use the Exchange Server Toolbox together with the latest version of hMail (5.6.7, released on 2017-12-14). During the installation process of the Exchange Server Toolbox you will be presented the option to download the latest hMail setup file.

 

Exchange Server Toolbox archiving to an external database is possible with the following database versions:

Microsoft SQL Server 2008 or newer

MySQL v. 5.5 or newer (adjusted value of 'max_allowed_packet' to > 50MB)

 
The service "NetTcpPortSharing" has to be available on your server to properly process and archive messages.

 

Exchange Server Toolbox needs to be installed on an Exchange Server running the hub-transport role and access to the Active Directory.

 

The Exchange Server Toolbox is designed to process up to 15 000 - 30 000 email messages per day. The exact number depends on the rules defined.

 

.NET Framework 4.7.2 is required and will be automatically downloaded by the setup if it has not already been installed.
 

The installation needs about 300MB of free disk space.

The RAM usage of the Exchange Server Toolbox depends on the size and number of emails that are processed in real-time.

The CPU requirement is predetermined by the Exchange Server.

 

The Exchange Server Toolbox Outlook Add-In is compatible with Microsoft Outlook 2007 - 2019.